Utilisatrice de Agilitest sur PC Portable Windows 10

Dépendances logicielles sous Windows 7 et supérieur pour Agilitest

24 mai 2019

Quel Windows pour Agilitest ?

Notre logiciel d’automatisation des tests fonctionnels Agilitest tourne sous Microsoft Windows, depuis la version Windows 7 jusqu’à Windows 10.

Le système d’exploitation privilégié pour Agilitest reste bien-entendu Windows 10 puisque c’est la dernière version en date qui équipe les ordinateurs neufs, et c’est aussi la version de Windows la plus utilisée depuis début 2018 (source statcounter.com).

Néanmoins, force est de constater que Windows 7 demeure bien implanté en entreprise. Son taux d’utilisation a beau être en chute libre depuis 2015, il conserve plus d’un tiers de parts de marché parmi les autres versions de Windows.

Pré-requis logiciels sous Windows

Bonne nouvelle, Agilitest supporte Microsoft Windows depuis la version Windows 7 (sans Service Pack) jusqu’à la version Windows 10. Dans tous les cas, la version 64 bits reste recommandée.

Il faudra tout de même disposer du .NET Framework. La version par défaut qui est proposée dans les mises à jour Windows 7 est la 4.7.2 mais la dernière version en date est .NET Framework 4.8.

L’absence, ou l’utilisation d’une version trop ancienne du .NET Framework entrainera un échec d’ouverture du canal navigateur avec une erreur du type :

 FAILED: ScriptATS java.lang.NullPointerException

Les autres dépendances concernent Java JDK qui devra être installé en version 9 et supérieur. La dernière version en date est Java SE Development Kit (JDK) 11.0.3.

Agilitest propose un menu de configuration qui vous permet de télécharger et d’installer le JDK en un clic. Il en est de même pour le générateur ActionTestScript (ATS), les outils Android ADB, et le processeur de rendu Apache FOP pour les rapports PDF.

Les navigateurs web utilisés pour vos tests logiciels devront idéalement être à jour, car Agilitest entretient une relation très proche avec eux. En effet, le langage de description des tests ActionTestScript s’interface avec le navigateur, et tous nos efforts se concentrent sur les dernières versions en date.

Néanmoins, si vous vouliez utiliser une version obsolète de votre navigateur comme par exemple Google Chrome 73 et antérieur, vous pourriez utiliser la méthode décrite sur cet article.