Management and project explorer

Project’s menu

Open the side bar to show various menus regarding your project:

In this menu you can find:

  • Executions management: To manage your executions and Jenkins Job
  • Project > Groups management: To open the group window that allows you to create and manage your groups
  • Project > Project properties: To access the properties of your project
  • Open in system explorer: To display your project in your Windows explorer
  • Project > Switch project: To switch with another open project
  • Close project: To close the current project in Agilitest
  • Project's call tree: To show all your called scripts

Open a new project

At the top left of Agilitest editor, click on Project > New project

Agilitest will create a new project with a project tree under the selected repository.

new project

Create a new component

To create a component that will be part of your project, click on Project > New component

When you create a new component, Agilitest allows you to select the following types:

Create ATS script: To create a new script or subscript.

Create Java script: It allows you to call for Java external code in Agilitest.

Create Javascript ATS script: This script file use the Javascript language

Create Python ATS script: This script file use the Python language

Create data files: To create a data file that will test multiple data. (Data Driven Testing)

Properties files: To use data with the "key = value" format

Create execution : To create a tests execution in order to manage the review of all your tests in a project, filtered according to multiple criterias.

Open an existing project

If you already have existing projects but they don’t appear in the project explorer, then you have to open them through Agilitest.

Click on Project > Open a project

Then, select the project depository at the root and validate by clicking on “Select a file

project explorer

Then, the project will open in the gilitest project explorer.

Project explorer presentation

The project explorer is a principal element to help you browse in Agilitest.

It has been optimized to obtain the best visibility of your projects, to facilitate the creation, execution and maintenance of your tests and to increase producitivity

It allows you to have a global view of a project and to bring global modifications as well as to limit the step-by-step method.

The project explorer is composed of:

  • Suite selection (1): A drop down list to define quickly the current suite for your project.
  • A set of actions (2): These buttons are used to : open a command line, execute the selected suite, show only favorites, toggle file focus and filter files
  • View selection (3): A drop down list to choose which type of script or items you wish to see appear.

Playlist of a project

A selected Playlist is a current Playslist (or suite) selected for a project. Each execution has parameters such as configuration options you can find the executions management menu.

To select a suite, click on the drop down menu made for suites

The purpose of selecting a suite for a project is to modify the project parameters at global scale and thus vary the values dependent of the these parameters which are used in the project scripts.

Example :

If you choose execution "A" with the Chrome browser and select execution "B" with the Firefox browser, when you use the Browser parameter in a script, the value will automatically be Firefox for execution "B" and Chrome for execution “A”.

Project explorer view

To help you in your organization and to have a clearer understanding of your project, all your project’s items are displayed in corresponding folders.

ATS scripts

The heart of your project with automated actions sequences (navigation, click, inputs, checks) written in ActionTestScript (.ats)

From the title bar you can : 

  • Add a new script
  • Add a folder
  • Search a script
  • Open in system explorer

Java ATS scripts

ATS scripts written directly in Java (.java) that can be used for advanced logic (loops, conditions, API…). They are run like ATS scripts and can be called as subscripts.

From the title bar you can : 

  • Add a new script
  • Add a folder
  • Open in system explorer

Javascript ATS scripts

Javascripts subscripts (.js) run by the GraalVM engine. Handy to compute values, transform data or reuse existing JS code. Called from a script via js://

From the title bar you can : 

  • Add a new script
  • Add a folder
  • Open in system explorer

Python ATS scripts

Python subscripts (.ps) run through GraalPy. Ideal for data processing or reusing Python libraries. Called via py://

‍From the title bar you can : 

  • Add a new script
  • Add a folder
  • Open in system explorer

Web services

‍‍From the title bar you can : 

  • Add a new Web service
  • Add a folder
  • Open in the system explorer

Data files

Data files (CSV, JSON, properties) used a source of data-driven tests with one execution per row.

From the title bar you can : 

  • Add a CSV file
  • Add a JSON file
  • Add a property file
  • Add a folder
  • Open in system explorer

Ressources file

Project’s resources (images, PDFs, files to upload, templates) reachable during execution through the assets:/// URL.

From the title bar you can : 

  • Refresh the menu
  • Open in system explorer

Libraries

External Java libraries (.jar) and Python packages used by your script. 

From the title bar you can : 

  • Add a library
  • Import a Python module
  • Open in system explorer

Execution results

Reports and artifacts produced by executions (target and test-output folders): HTM/XML reports, screenshots, logs.

From the title bar you can : 

  • Clean folder and move to trash the results
  • Refresh the menu
  • Open in system explorer

🔸Warning

If an execution is executed outside of Agilitest (with a command line for example), Agilitest may not be aware of the results. Click on the refresh button to update the folder.

Script management

A tree structure will be indicated when a directory is created in an existing directory.

To do that, do a right click on an existing folder to create another one that will be part of that folder.

You can also rename your folders by doing a right click on the folder > “Rename

You can delete your ATS script with a right click directly on the script situated in the project explorer.

When you delete a script, a window will appear to confirm that you wish to delete the selected script. This window indicates that th suppressed ATS script will be sent to the bin of your Windows system.

If deleting the script was an error, you can simply restore the script by recovering it from the bin.

Command lines

There are three ways to access the command line panel.

  1. Single Playlist

From the project explorer, click on “command lines

         2. Script

Do a right click on the script you want to execute with command lines

        3. Multiple Playlists

From the executions management menu, in “Executions”, click on the corresponding button.

This panel allows you to obtain the necessary command lines for each launcher.

You can execute these command lines by clicking on the “Open terminal” button.

To execute in Java, you will need 2 command lines.

The first to compile in Java and the second to execute in Java.

Package a project

When you want to add scripts from one test project to another, you can package the entire project and then add it to the libraries of the target project.

To do that, click on Project tools > Package project 

This will create the .jar file.

Open the directory in which there is the .jar file. 

Switch to the other project using the “Switch Project” command.

Click the Libraries tab in the Project Explorer > Open in system explorer.

Copy the .jar file into the libraries directory.

Reload the project to update it in Project Tools > Reload Project

From now on, scripts belonging to the original project are marked with the “lib” label.

These scripts can be used but cannot be modified directly.

Dialogue with AI

Right click on a script and select "Chat with AI agent"

The agent's system prompt focuses on three specific intentions: 

  • Writing the description field (1-2 sentences to copy and paste)
  • A written analysis of robustness
  • Relevance, and suggestions for structural improvements (grouping, sub-scripts, naming).

 Functions requiring insertion into the script (comments, assertions) are intentionally disabled until they are automatically branched.

On this page

// TOC MANAGEMENT